Molecular Visualization using VMD (Visual Molecular Dymanics)

VMD, a molecular graphics program, is developed in the Theoretical and Computational Biophysics group (Univ. of Illinois) together with other software (eg. NAMD) to simulate molecular systems. The group is lead by Klaus Schulten.

The tutorial will first have some insight into a raw PDB file entry. Then the tutorial will guide you through the topics given in the table of contents.

The structures used in this tutorial are Hen Egg Lysozyme (1HEW) for the basic parts, a Phosphotransferase from E. coli (1WCR), HSP90 (1YER and 2IOR) for alignment and electrostatic calculations/visualizations.

Exploring the RCSB Protein Data Bank (PDB)

Goal: getting familiar with the PDB Database

 * Open a browser and go to: http://www.rcsb.org
 * Search for the PDB ID: 1HEW
 * On the right part of the Structure Explorer page, click on Download_Files 
    -> PDB_File and save 1HEW.pdb as a PDB file (Text)
 * Open this file with a text editor and answer the following questions: 

Questions:

  1. What protein is this_?_
  2. Does it contain any ligands? If yes, which_?_
  3. What technique was used to determine its structure_?_
  4. What is the resolution of the structure_?_
  5. Where could we find more details about the structure determination procedure_?_

Protein and ligand visualization and selection of structure parts (1HEW)

Goal: identification of the nature of inter-molecular interactions

  * Open the VMD Program (vmd)
  * In VMD_Main window, go to: File 
     -> New_Molecule; click Browse button and browse for downloaded in Task 1 file 1HEW.pdb, 
     then click Load and close the Molecule_File_Browser window
  * In VMD_Main window, go to: Graphics -> Representations...
    * Type 'protein' (instead of 'all') in the Selected_Atoms field
    * Click on: Create_Rep button
    * For the new representation choose Secondary Structure under Coloring_Method and 
      New_Cartoon under Drawing_Method
  * Note that double click on representation list window (with Style, Color, Selection table) 
    switches on and off displaying of representations. Switch off the other represenations and 
    leave only the new one, and answer the following questions: 

Questions:

  1. How many alpha-helices are present in the protein_?_
  2. How many beta-sheets are present in the protein_?_
  3. How many beta-strands form the beta-sheet? Are they parallel or anti-parallel_?_

Create Graphics representations

Explore the capabilities to visualize structural parts

  * In the Drawing_Method field, change from New_Cartoon to Surf
  * In the Coloring_Method field, change from Secondary Structure 
    to Backbone (protein backbone will be rendered in green and the 
    side chains in blue)
  * Click on Create_Rep button and replace 'protein' by 'resname NAG' in the Selected_Atoms field 
  * Change the Drawing_Method from Surf to Licorice and the Coloring_Method 
    from Backbone to Name, and answer the following question:
  1. Does the inhibitor interact mostly with the protein backbone or side chains_?_
   * Click on representation number 2 (Surface-Backbone-protein) and change the Coloring Method 
     from Backbone to Res_Type (apolar residue are represented in white, neutral polar in green, 
     positively charged in blue, and negatively charged in red). It will give you an idea of 
     the chemical nature of the enzyme's active site.

Inspecting Protein Structure: The Ramachandran Plot

Goal: analysis of protein structure via the Ramachandran Plot

  *  In VMD_Main window, go to Extensions -> Analysis -> Ramachandran Plot
  *  In the Molecule menu select 1HEW.pdb
  *  Note that several points (on the right hand side of the graph) fall outside of the allowed conformational region
  *  Click on these points (yellow squares) to identify these residues and answer the following question:
  1. Explain why these residues can adopt the so-called forbidden conformations_?_
  * Close the VMD program (File -> Quit)

Coloring Chains and Hydrogen patterns

Goal: identification of the nature of inter-molecular interactions

  * Download, save a molecule with PDB ID 1WCR (as in Task 1)
  * Open VMD and load this molecule - you should see the phosphotransferase enzyme IIA
    from Escherichia coli in the VMD graphical window
  * Color it by chain
    * Create a new represenation and 
      * change the Drawing_Method to HBonds 
      * and the Coloring_Method to ColorID . 
      * Set ColorID to 4 (yellow)
    * Relax the hydrogen-bond parameters a bit (distance cutoff: 3.5, and angle cutoff: 25)
    * Increase Line_Thickness to 6
    * Manipulate the model and answer the following questions: 
  1. What type of hydrogen-bond pattern do you observe, i.e., intra- or interchain_?_
  2. Based on the hydrogen-bond pattern, what kind of interactions (hydrophilic or hydrophobic) do you think is mainly responsible for keeping the protein structure as a trimer (3 units)_?_

Alignment of proteins

Goal: Compare structures from different organisms or different folds

    * Sometimes similar proteins exist in different species - they may perform the same function,
      but have different sequences. Therefore, it is useful to compare structures of these proteins. 
      To do that, one needs to align the proteins based on their sequence 
      and sometimes also taking the structure into account.
    * Download from RCSB the pdb entries **2IOR** and **1YER** and store them in a folder on the desktop.
  1. How do these protein differ_?_ Look for answers on the PDB webpages and/or in the downloaded files.
   * Load both structures into vmd
  1. Can you see both proteins_?_ Search for them by zooming and/or rotating (translation mode can be switched on by pressing 'T' and switched off by pressing 'R' on the keyboard).
   * To align the proteins Go to the menu: Extensions->Analysis->Multiseq
   * You need to specify a folder for temporary files. Create an empty folder on the desktop and choose it
   * Next, in the window that appears, select Tools->Stamp Structural Alignment and press Ok.
   * If the center of your protein is shifted now, Select Display -> Reset view
   * Please note, while closing the panel of the Multiseq Analysis, the original representation is started again.
     Go to Display -> Representations and enable the Cartoon Representation again.
   * You can color the structures differently using the Graphical Representations to clearly see the differences.
   * Create an additional representation for each protein that selects the following atoms: 
     not (protein or water). Display this in Licorice represenation.
  1. What region displays largest difference between the two structures_?_
  * In the VMD Main window select the molecule of 1yer and right click on it to save its coordinates.
    Choose only the protein part (chain A) in 'Selected Atoms' and save it in a file called 1YER_aligned.pdb and repeat these steps also for the other molecule 2ior_aligned.pdb
  * Close the VMD program 

Visualization of electrostatic potentials

Goal: Visualize possible interaction sites on proteins

  * Start VMD again and use the aligned Proteins from the previous section (load the previously saved coordinates). 
    The proteins should show up as aligned entities.
  * Go to the PDB2PQR webserver: http://nbcr-222.ucsd.edu/pdb2pqr_2.1.1/
  * Upload one of the aligned coordinate files. 
    Choose the force field (AMBER) and naming scheme (AMBER), and click ’Submit’.
  * Save the output files (xxxx_aligned.in, xxxx_aligned.propka and xxxx_aligned.pqr) on disk.
  * Press "Run APBS" -> Launch
  * Again, save the output files, espcially the *.dx.gz grid files. 
    You might want to look at the program output and error logs if there are errors or warnings.
  * Repeat for both structures and unpack the *.dx.gz file.

In the respective pqr files, what are the net charges for the two proteins_?_

  * To visualize the electrostatic potential, select in the vmd main window the molecule 1yer.
  * Go to File-> Load data in molecule. Select the corresponding dx grid file from your apbs output Press Load.
  * In Graphics Representation, change the standard representation to New Cartoon.
  * Create a new representation, Color by ID (blue), Select drawing method Isosurface. Select an Isovalue of 3 
    and draw as Solid surface.
  * Again Create a new representation. Color by ID (red), Select again drawing method Isosurface with an Isovalue of -3.
    also draw as Solid surface.
  * Repeat the steps with the other molecule. 

What are the differences between the electrostatic potentials of the two proteins? From which species are the respective proteins from_?_

Tutor only

Navigation
Print/export
QR Code
QR Code courses:public:vmd (generated for current page)